アプリ開発・Linuxサーバ環境構築からSEOまで初心者向けのプログラミング技術を紹介しています。

Eclipseでデバックできない~その2~

2011年1月18日(火) 5:01 PM

Eclipseでandroidプロジェクトをデバックしようとしても、Errorマークが出て、デバックできない。

Errorマークにカーソルを合わせると、

構文エラー。注釈はソース・レベルが 1.5 の場合にのみ使用可能です

という表示が出ています。

また、コンソールの出力画面には、

Android requires .class compatibility set to 5.0. Please fix project properties. 

の文字が出力されていました。

console output

エラーメッセージは、コンパイラーを JDK1.5に変更する必要があるという意味だったみたいです。

Eclipseのメニューで、「ウィンドウ(W)」「設定」

設定画面から、「Java」「コンパイラー」

「コンパイラー準拠レベル(I)」を ”1.6” →”1.5”へ変更。

すると、プロジェクトが再ビルドされて、エラーがなくなります。

この後、「コンパイラー準拠レベル(I)」を ”1.5” →”1.6”に戻しても、なぜかerrorが出なくなりました。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

コメントの更新情報

トラックバックURL

http://appli-info.jp/2011/01/18/eclipse%e3%81%a7%e3%83%87%e3%83%90%e3%83%83%e3%82%af%e3%81%a7%e3%81%8d%e3%81%aa%e3%81%84%ef%bd%9e%e3%81%9d%e3%81%ae%ef%bc%92%ef%bd%9e/trackback/

  • 広告

* RSS FEED