Eclipseでデバックできない~その2~

Eclipseでandroidプロジェクトをデバックしようとしても、Errorマークが出て、デバックできない。

Errorマークにカーソルを合わせると、

構文エラー。注釈はソース・レベルが 1.5 の場合にのみ使用可能です

という表示が出ています。

また、コンソールの出力画面には、

Android requires .class compatibility set to 5.0. Please fix project properties. 

の文字が出力されていました。

console output

エラーメッセージは、コンパイラーを JDK1.5に変更する必要があるという意味だったみたいです。

Eclipseのメニューで、「ウィンドウ(W)」「設定」

設定画面から、「Java」「コンパイラー」

「コンパイラー準拠レベル(I)」を ”1.6” →”1.5”へ変更。

すると、プロジェクトが再ビルドされて、エラーがなくなります。

この後、「コンパイラー準拠レベル(I)」を ”1.5” →”1.6”に戻しても、なぜかerrorが出なくなりました。

コメントする

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です